summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2021-08-15 08:46:36 +0200
committerBrice Waegeneire <brice@waegenei.re>2021-09-04 09:18:37 +0200
commit2226d5b9590840f6fdc0d5c03b14c9d050435c4e (patch)
tree5e373a8e703e8ce9dd98d70fe07c37c561807ce1 /gnu/packages/xorg.scm
parente12ba46c4c0686271a7e420d10fdda2b427bcf4d (diff)
downloadguix-patches-2226d5b9590840f6fdc0d5c03b14c9d050435c4e.tar
guix-patches-2226d5b9590840f6fdc0d5c03b14c9d050435c4e.tar.gz
gnu: Add setroot.
* gnu/packages/xorg.scm (setroot): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6f9633985e..cae0fb3f73 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6925,3 +6925,38 @@ an existing user-specified one, writes a cookie to it, and then starts the
the server and cleaning up before returning the exit status of the command.")
(license (list license:x11 ; the script
license:gpl2+)))) ; the man page
+
+(define-public setroot
+ (package
+ (name "setroot")
+ (version "2.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ttzhou/setroot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w95828v0splk7bj5kfacp4pq6wxpyamvyjmahyvn5hc3ycq21mq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "PREFIX="
+ "xinerama=1")
+ #:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libx11" ,libx11)
+ ("libxinerama" ,libxinerama)))
+ (home-page "https://github.com/ttzhou/setroot")
+ (synopsis "Simple X background setter inspired by imlibsetroot and feh")
+ (description "Setroot is a lightweight X background setter with feh's
+syntax without its image viewing capabilities. It supports multiple monitors
+and can restore previously set wallpapers and options.")
+ (license license:gpl3+)))