summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-10 16:13:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-10 16:13:07 +0300
commit1f18f18e85da6652a078f24220d4f4b4957801a0 (patch)
treed11a83726a8a0f5317ffb2b7c8b7669b4de2e98e /gnu/packages/xorg.scm
parentf0ad43dfdd68bd0a2ff20cd588128a8666df5fea (diff)
downloadguix-patches-1f18f18e85da6652a078f24220d4f4b4957801a0.tar
guix-patches-1f18f18e85da6652a078f24220d4f4b4957801a0.tar.gz
gnu: xf86-video-freedreno: Fix building.
* gnu/packages/xorg.scm (xf86-video-freedreno)[arguments]: Override the 'boostrap phase.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 79139d01c1..def751c62c 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2920,7 +2920,13 @@ framebuffer device.")
`(#:configure-flags
(list (string-append "--with-xorg-conf-dir="
(assoc-ref %outputs "out")
- "/share/X11/xorg.conf.d"))))
+ "/share/X11/xorg.conf.d"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; autogen.sh calls configure unconditionally.
+ (invoke "autoreconf" "-vfi"))))))
(home-page "https://www.x.org/wiki/")
(synopsis "Adreno video driver for X server")
(description