summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:26 +0200
commit0bb061190eca6534951d6ab1ee2e9068f1f9dd20 (patch)
tree847e1798295b454f0feafa39b1937bf0ea6be9b8 /gnu/packages/xorg.scm
parenta2bd3758c14b05038c861419b6b6816379514620 (diff)
downloadguix-patches-0bb061190eca6534951d6ab1ee2e9068f1f9dd20.tar
guix-patches-0bb061190eca6534951d6ab1ee2e9068f1f9dd20.tar.gz
gnu: console-setup: Use G-expressions.
* gnu/packages/xorg.scm (console-setup)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm47
1 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ff633a192c..cbb1dc7779 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6585,29 +6585,30 @@ output.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- (list (string-append "SHELL=" (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'patch-file-names
- (lambda* (#:key inputs #:allow-other-keys)
- ;; 'ckbcomp' calls out to 'cat' (!). Give it the right file
- ;; name.
- (substitute* '("Keyboard/ckbcomp")
- (("\"cat ")
- (format #f "\"~a " (search-input-file inputs "bin/cat"))))))
- (add-before 'build 'make-doubled-bdfs
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "-C" "Fonts" "doubled_bdfs"
- make-flags)))
- (replace 'install
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "install-linux"
- make-flags))))))
+ (list #:make-flags
+ #~(list (string-append "SHELL=" (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "prefix=" #$output))
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; 'ckbcomp' calls out to 'cat' (!). Give it the right file
+ ;; name.
+ (substitute* '("Keyboard/ckbcomp")
+ (("\"cat ")
+ (format #f "\"~a "
+ (search-input-file inputs "bin/cat"))))))
+ (add-before 'build 'make-doubled-bdfs
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "-C" "Fonts" "doubled_bdfs"
+ make-flags)))
+ (replace 'install
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "install-linux"
+ make-flags))))))
(native-inputs
(list pkg-config
bdftopcf