summaryrefslogtreecommitdiff
path: root/gnu/packages/xnee.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-01-24 00:55:42 +0100
committerAndreas Enge <andreas@enge.fr>2015-01-24 09:56:39 +0100
commit6e8586fb478f9cc38691bfc549f7f1c536668ea0 (patch)
tree0e5091f031238eb11ee781294fcaddae681c25be /gnu/packages/xnee.scm
parent02bb6b45e472131d882c2466f3a4104ee7d56631 (diff)
downloadguix-patches-6e8586fb478f9cc38691bfc549f7f1c536668ea0.tar
guix-patches-6e8586fb478f9cc38691bfc549f7f1c536668ea0.tar.gz
gnu: xnee: Update to 3.19 and add input GTK+.
* gnu/packages/xnee.scm (xnee): Update to 3.19. This requires gtk+-2 as additional input.
Diffstat (limited to 'gnu/packages/xnee.scm')
-rw-r--r--gnu/packages/xnee.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/xnee.scm b/gnu/packages/xnee.scm
index 795f355d09..4e9135dd5b 100644
--- a/gnu/packages/xnee.scm
+++ b/gnu/packages/xnee.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,30 +22,32 @@
#:use-module (guix licenses)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages xorg)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xorg))
(define-public xnee
(package
(name "xnee")
- (version "3.18")
+ (version "3.19")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/xnee/xnee-"
version ".tar.gz"))
(sha256
(base32
- "0j6b27ry0w765040089ppwwdl313xfgn31yh3fpqy4gk0jv23m94"))))
+ "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
(build-system gnu-build-system)
(inputs
- `(("recordproto" ,recordproto)
+ `(("gtk+", gtk+-2)
("inputproto" ,inputproto)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
("libxi" ,libxi)
("libxtst" ,libxtst)
+ ("recordproto" ,recordproto)
("xextproto" ,xextproto)
- ("libxext" ,libxext)
- ("xproto" ,xproto)
- ("libx11" ,libx11)))
+ ("xproto" ,xproto)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://www.gnu.org/software/xnee/")