summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-15 15:45:27 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-15 19:13:01 +0200
commitee617c4800c84c21a976a36b9f612e5a7d05d9f2 (patch)
tree51db31bc48775c36201a4aa32506b1cc7a5b4ea8 /gnu/packages/xml.scm
parent179a949e60ff15754f5faf3ec6276ba9b20da86c (diff)
downloadguix-patches-ee617c4800c84c21a976a36b9f612e5a7d05d9f2.tar
guix-patches-ee617c4800c84c21a976a36b9f612e5a7d05d9f2.tar.gz
gnu: python-lxml: Add 4.7.1.
* gnu/packages/xml.scm (python-lxml-4.7): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 64092b8d2d..db004c11b6 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2016, 2018-2019, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
@@ -2529,6 +2529,18 @@ because lxml.etree already has its own implementation of XPath 1.0.")
libxml2 and libxslt.")
(license license:bsd-3))) ; and a few more, see LICENSES.txt
+(define-public python-lxml-4.7
+ (package
+ (inherit python-lxml)
+ (version "4.7.1")
+ (source
+ (origin
+ (inherit (package-source python-lxml))
+ (uri (pypi-uri "lxml" version))
+ (sha256
+ (base32
+ "090viyanaki4q7w7i000xl0qh4in52bkl3qal55sz2bbm8w3hqd1"))))))
+
(define-public python2-lxml
(package-with-python2 python-lxml))