summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-23 17:12:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-23 20:27:48 +0100
commite44a0d2ce2aff15497106ed64edb0f7f6faaafb8 (patch)
tree875af8233b223549fbb9c63b13e5b0d81c016596 /gnu/packages/xml.scm
parentd04261241baa857a412053730ed230b20096bbda (diff)
downloadguix-patches-e44a0d2ce2aff15497106ed64edb0f7f6faaafb8.tar
guix-patches-e44a0d2ce2aff15497106ed64edb0f7f6faaafb8.tar.gz
gnu: java-simple-xml: Delete failing test.
This is a follow-up to commit 8e32bd1720336ec62258cb842dce812f7f979d04. * gnu/packages/xml.scm (java-simple-xml)[arguments]: Disable test by deleting it, as #:test-exclude doesn't have any effect.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9f83c7d079..b89115a051 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1553,11 +1553,14 @@ Excel(TM) since version 2007.")
(arguments
`(#:build-target "build"
#:test-target "test"
- ;; This test sometimes fails with an out of memory exception
- #:test-exclude (list "**/NoAnnotationsRequiredTest.java")
#:phases
(modify-phases %standard-phases
- (replace 'install (install-jars "jar")))))
+ (replace 'install (install-jars "jar"))
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ ;; This test sometimes fails with an out of memory exception
+ (delete-file
+ "test/src/org/simpleframework/xml/core/NoAnnotationsRequiredTest.java"))))))
(native-inputs
(list unzip))
(home-page "http://simple.sourceforge.net/")