summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/xml.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8f4c9706bd..bc76a95c59 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1001,21 +1001,21 @@ server, collect the answer, and finally decoding the XML to Perl.")
(native-inputs
(list perl-module-build perl-uri perl-class-data-inheritable))
(propagated-inputs
- `(("perl-class-errorhandler" ,perl-class-errorhandler)
- ("perl-datetime" ,perl-datetime)
- ("perl-datetime-format-flexible" ,perl-datetime-format-flexible)
- ("perl-datetime-format-iso8601" ,perl-datetime-format-iso8601)
- ("perl-datetime-format-mail" ,perl-datetime-format-mail)
- ("perl-datetime-format-natural" ,perl-datetime-format-natural)
- ("perl-datetime-format-w3cdtf" ,perl-datetime-format-w3cdtf)
- ("perl-feed-find" ,perl-feed-find)
- ("perl-html-parser" ,perl-html-parser)
- ("perl-libwww-perl" ,perl-libwww)
- ("perl-module-pluggable" ,perl-module-pluggable)
- ("perl-uri-fetch" ,perl-uri-fetch)
- ("perl-xml-atom" ,perl-xml-atom)
- ("perl-xml-libxml" ,perl-xml-libxml)
- ("perl-xml-rss" ,perl-xml-rss)))
+ (list perl-class-errorhandler
+ perl-datetime
+ perl-datetime-format-flexible
+ perl-datetime-format-iso8601
+ perl-datetime-format-mail
+ perl-datetime-format-natural
+ perl-datetime-format-w3cdtf
+ perl-feed-find
+ perl-html-parser
+ perl-libwww
+ perl-module-pluggable
+ perl-uri-fetch
+ perl-xml-atom
+ perl-xml-libxml
+ perl-xml-rss))
(home-page "https://metacpan.org/release/XML-Feed")
(synopsis "XML Syndication Feed Support")
(description "@code{XML::Feed} is a syndication feed parser for both RSS and