summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 17:58:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-03 01:52:44 +0100
commitbc134c77e0b4406f735047409d28b2455035b195 (patch)
treec069252162130c27dac68d4a4dcf0021a8dde27d /gnu/packages/xml.scm
parent51058cb2324d979c5f54fcc4005dfbfe2e0345ee (diff)
downloadguix-patches-bc134c77e0b4406f735047409d28b2455035b195.tar
guix-patches-bc134c77e0b4406f735047409d28b2455035b195.tar.gz
gnu: pugixml: Update to 1.10.
* gnu/packages/xml.scm (pugixml): Update to 1.10. [source]: Remove obsolete patch. * gnu/packages/patches/pugixml-versioned-libdir.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c2a4dda552..fd49a9c5bd 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -882,20 +882,18 @@ the form of functions.")
(define-public pugixml
(package
(name "pugixml")
- (version "1.9")
+ (version "1.10")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/zeux/pugixml/releases/download/v"
version "/pugixml-" version ".tar.gz"))
- (patches (search-patches "pugixml-versioned-libdir.patch"))
(sha256
- (base32
- "19nv3zhik3djp4blc4vrjwrl8dfhzmal8b21sq7y907nhddx6mni"))))
+ (base32 "02l7nllhydggf7s64d2x84kckbmwag4lsn28sc82953hnkxrkwsm"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
- #:tests? #f)) ;no tests
+ #:tests? #f)) ; no tests
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://pugixml.org")