summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 16:05:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 16:05:21 -0400
commitb865a21c3475b2c66a0b5cf07d0a0e4221a92516 (patch)
treea65fe7e2327ef7d228ce6488634e6a94bd86cfcb /gnu/packages/xml.scm
parentd0bff5dd6dbfa89b7360c0f3fa5a77f73c496cb0 (diff)
downloadguix-patches-b865a21c3475b2c66a0b5cf07d0a0e4221a92516.tar
guix-patches-b865a21c3475b2c66a0b5cf07d0a0e4221a92516.tar.gz
gnu: python-elementpath: Update to 2.0.3.
* gnu/packages/xml.scm (python-elementpath): Update to 2.0.3. [arguments]: Add field; disable the tests.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index af2da1bbb6..dddb056a0f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2201,15 +2201,18 @@ modular implementation of XML-RPC for C and C++.")
(define-public python-elementpath
(package
(name "python-elementpath")
- (version "1.4.0")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "elementpath" version))
(sha256
(base32
- "15h7d41v48q31hzjay7qzixdv531hnga3h35hksk7x52pgqcrkz7"))))
+ "1kxx573ywqfh6j6aih2i6hhsya6kz79qq4bgz6yskwk6b18jyr8z"))))
(build-system python-build-system)
+ ;; The test suite is not run, to avoid a dependency cycle with
+ ;; python-xmlschema.
+ (arguments `(#:tests? #f))
(home-page
"https://github.com/sissaschool/elementpath")
(synopsis