summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorDavid Larsson <david.larsson@selfhosted.xyz>2021-05-15 20:52:50 +0200
committerMarius Bakke <marius@gnu.org>2021-05-18 22:23:49 +0200
commitb58efbc6611550ad9234163e198ff71ace5306ea (patch)
treea3d94d94d4c139d9a5d9b70320608e9700260fb7 /gnu/packages/xml.scm
parent6f20fa3b8b558e5e8452eb48a4e992c4b0958c35 (diff)
downloadguix-patches-b58efbc6611550ad9234163e198ff71ace5306ea.tar
guix-patches-b58efbc6611550ad9234163e198ff71ace5306ea.tar.gz
gnu: Add libxml2-xpath0.
* gnu/packages/patches/libxml2-xpath0-Add-option-xpath0.patch: New file... * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/xml.scm (libxml2-xpath0): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index fd3ea8c0ae..ad2e3ec6c9 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -218,6 +219,19 @@ hierarchical form with variable field lengths.")
project (but it is usable outside of the Gnome platform).")
(license license:x11)))
+(define-public libxml2-xpath0
+ (package/inherit libxml2
+ (name "libxml2-xpath0")
+ (source (origin
+ (inherit (package-source libxml2))
+ (patches (append (search-patches
+ "libxml2-xpath0-Add-option-xpath0.patch")
+ (origin-patches (package-source libxml2))))))
+ (description
+ "Libxml2-xpath0 is like libxml2 but with a patch applied that
+provides an @code{--xpath0} option to @command{xmllint} that enables it
+to output XPath results with a null delimiter.")))
+
(define-public libxlsxwriter
(package
(name "libxlsxwriter")