summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-27 21:13:52 -0400
committerMark H Weaver <mhw@netris.org>2018-11-14 23:44:06 -0500
commitaa6f87a2b984039229abbaba08c06415a782badc (patch)
treecba08fd7f887fb72936db3b26a5e79724bd41a1b /gnu/packages/xml.scm
parent9dcfd6aac97044474b3df9aeb67a56e2fdaa87fb (diff)
downloadguix-patches-aa6f87a2b984039229abbaba08c06415a782badc.tar
guix-patches-aa6f87a2b984039229abbaba08c06415a782badc.tar.gz
gnu: xml: Return #t from all phases.
* gnu/packages/xml.scm (python-libxml2, perl-xml-sax, xlsx2csv, libxls) (java-kxml2): Return #t from all phases.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7f7ff6fc38..3ac01133e5 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -187,7 +187,8 @@ project (but it is usable outside of the Gnome platform).")
(format #f "ROOT = r'~a'" libxml2))
;; For 'iconv.h'.
(("/opt/include")
- (string-append glibc "/include")))))))))
+ (string-append glibc "/include"))))
+ #t)))))
(inputs `(("libxml2" ,libxml2)))
(synopsis "Python bindings for the libxml2 library")))
@@ -552,7 +553,8 @@ that allow you to generate HTML from an RSS, convert between 0.9, 0.91, and
(setenv "PERL5LIB"
(string-append (getenv "PERL5LIB") ":"
(assoc-ref outputs "out")
- "/lib/perl5/site_perl")))))))
+ "/lib/perl5/site_perl"))
+ #t)))))
(home-page "https://metacpan.org/release/XML-SAX")
(synopsis "Perl API for XML")
(description "XML::SAX consists of several framework classes for using and
@@ -1220,7 +1222,7 @@ elements to their parents
(substitute* "test/run"
;; Run tests with `python' only
(("^(PYTHON_VERSIONS = ).*" all m) (string-append m "['']")))
- (zero? (system* "test/run")))))))
+ (invoke "test/run"))))))
(home-page "https://github.com/dilshod/xlsx2csv")
(synopsis "XLSX to CSV converter")
(description
@@ -1269,7 +1271,7 @@ files. It is designed to be fast and to handle large input files.")
;; Bootstrapping is required in order to fix the test driver script.
(replace 'bootstrap
(lambda _
- (zero? (system* "bash" "bootstrap")))))))
+ (invoke "bash" "bootstrap"))))))
(native-inputs
`(("unzip" ,unzip)
("autoconf" ,autoconf)
@@ -1870,7 +1872,8 @@ low memory footprint.")
(modify-phases %standard-phases
(add-before 'build 'copy-resources
(lambda _
- (copy-recursively "src/main/resources" "build/classes"))))))
+ (copy-recursively "src/main/resources" "build/classes")
+ #t)))))
(inputs
`(("java-xpp3" ,java-xpp3)))
(native-inputs