summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-23 16:22:18 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-23 16:22:31 +0100
commita9d540cfa87ef3a5de3296188f650fb0d037efbd (patch)
tree8bbe3bbea70e84b627dfab6a2f515a12c8280b19 /gnu/packages/xml.scm
parentb35581bd63d929e83d18f42b067f63efc867353c (diff)
downloadguix-patches-a9d540cfa87ef3a5de3296188f650fb0d037efbd.tar
guix-patches-a9d540cfa87ef3a5de3296188f650fb0d037efbd.tar.gz
gnu: python-lxml: Update to 4.6.3 [security fixes].
Fixes at least CVE-2020-27783 and CVE-2021-28957. * gnu/packages/xml.scm (python-lxml): Update to 4.6.3.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 64d5e51fb4..738f375ac9 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2421,13 +2421,13 @@ because lxml.etree already has it's own implementation of XPath 1.0.")
(define-public python-lxml
(package
(name "python-lxml")
- (version "4.5.2")
+ (version "4.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "lxml" version))
(sha256
- (base32 "1xhx76hr1w3lllfcg9a01f2y0zwyf59ijnvlh08299mjh8b3mhfd"))))
+ (base32 "0s14r1w2x9sdlcsw8mxiqgw4rz5zs5lpqpxrfyn4a1mkndqqbdrr"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases