summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 13:30:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 17:45:41 +0100
commita4b96726b510979c0784dab81ffd68349788554b (patch)
tree69b0274567b396e26232c47d0d2bd449b80cbaa9 /gnu/packages/xml.scm
parent4bad4fbdf88b97274a18e6aa403ffea14ef11d80 (diff)
downloadguix-patches-a4b96726b510979c0784dab81ffd68349788554b.tar
guix-patches-a4b96726b510979c0784dab81ffd68349788554b.tar.gz
gnu: java-jettison: Don't use unstable tarball.
* gnu/packages/xml.scm (java-jettison)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 19391ea8aa..461c021967 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1930,12 +1930,14 @@ and from a Java application. It provides a standard pull parser interface.")
(name "java-jettison")
(version "1.3.7")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/codehaus/jettison/archive/"
- "jettison-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/codehaus/jettison.git")
+ (commit (string-append "jettison-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0rdhfyxywvga5wiwasc04iqnxyixn3rd8wj01c9ymhvwc3h6dpqg"))))
+ "15sydmi5chdh4126qc7v8bsrp7fp4ldaya8a05iby4pq2324q0qw"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "jettison.jar"