summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 20:18:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 20:36:33 +0100
commit8fda8b7d6addf5e354e58e449c1a4a8894cb658b (patch)
treef6c43f98426409fc802cfd255f85e503c79999ee /gnu/packages/xml.scm
parent5efa04dd935ecf6f7803501b1b8952810f4330ad (diff)
downloadguix-patches-8fda8b7d6addf5e354e58e449c1a4a8894cb658b.tar
guix-patches-8fda8b7d6addf5e354e58e449c1a4a8894cb658b.tar.gz
gnu: python-elementpath: Move to (gnu packages xml).
* gnu/packages/python-xyz.scm (python-elementpath): Move from here ... * gnu/packages/xml.scm (python-elementpath): ... to here.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5b9082cb26..83a2f1b713 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2050,6 +2051,31 @@ server using HTTP, and gets back the response as XML. This library provides a
modular implementation of XML-RPC for C and C++.")
(license (list license:psfl license:expat))))
+(define-public python-elementpath
+ (package
+ (name "python-elementpath")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "elementpath" version))
+ (sha256
+ (base32
+ "1syn2z543brab23dskh3fjd9pqvz6npqbcicrs2d88dbg26xl08p"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/sissaschool/elementpath")
+ (synopsis
+ "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
+ (description
+ "The proposal of this package is to provide XPath 1.0 and 2.0 selectors
+for Python's ElementTree XML data structures, both for the standard
+ElementTree library and for the @uref{http://lxml.de, lxml.etree} library.
+
+For lxml.etree this package can be useful for providing XPath 2.0 selectors,
+because lxml.etree already has it's own implementation of XPath 1.0.")
+ (license license:expat)))
+
(define-public python-xmltodict
(package
(name "python-xmltodict")