summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-03-28 10:40:19 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-29 11:56:05 +0200
commit5d32fa526d9d054f21fa3a40b7cb3e3cf468e4b9 (patch)
treea50b7b3caa7a128dd6ed87ce598b3e7f4e051ba2 /gnu/packages/xml.scm
parent109f13c0981b8134c98a2326f22cc837ec523712 (diff)
downloadguix-patches-5d32fa526d9d054f21fa3a40b7cb3e3cf468e4b9.tar
guix-patches-5d32fa526d9d054f21fa3a40b7cb3e3cf468e4b9.tar.gz
gnu: Add libxlsxwriter.
* gnu/packages/xml.scm (libxlsxwriter): New variable. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index defc0323e6..130fe45995 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -29,6 +29,8 @@
;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,6 +79,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix utils)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config))
@@ -215,6 +218,49 @@ hierarchical form with variable field lengths.")
project (but it is usable outside of the Gnome platform).")
(license license:x11)))
+(define-public libxlsxwriter
+ (package
+ (name "libxlsxwriter")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jmcnamara/libxlsxwriter")
+ (commit (string-append "RELEASE_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "070pfqggia71z4ichr5yrwfndfz903z941ns72vy0lvb1mpp7g05"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove bundled minizip source
+ '(begin
+ (delete-file-recursively "third_party/minizip")
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "USE_STANDARD_TMPFILE=1"
+ "USE_SYSTEM_MINIZIP=1")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (inputs
+ `(("minizip" ,minizip)))
+ (home-page "https://github.com/jmcnamara/libxlsxwriter")
+ (synopsis "C library for creating Excel XLSX files")
+ (description
+ "Libxlsxwriter is a C library that can be used to write text, numbers,
+formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
+ (license (list license:bsd-2
+ license:public-domain)))) ; third_party/md5
+
;; This is the latest stable release.
(define-public libxmlplusplus
(package