summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-17 01:25:52 +0200
committerMarius Bakke <marius@gnu.org>2021-09-17 01:25:52 +0200
commit5c3cb22c9b2810669999e044b2de5e9331011a83 (patch)
tree3276e19cc1a0af3cece6ce4f2bfa930901888bb4 /gnu/packages/xml.scm
parentc896287ce5eff968a0b323f3a069653a64b96b4c (diff)
parent2a054d29dcfd4b68ed3914886b637f93ac7a0a72 (diff)
downloadguix-patches-5c3cb22c9b2810669999e044b2de5e9331011a83.tar
guix-patches-5c3cb22c9b2810669999e044b2de5e9331011a83.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm75
1 files changed, 0 insertions, 75 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9505bf789c..3b0ab90574 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -295,81 +295,6 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
(license (list license:bsd-2
license:public-domain)))) ; third_party/md5
-;; This is the latest stable release.
-(define-public libxmlplusplus
- (package
- (name "libxmlplusplus")
- (version "3.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libxmlplusplus/libxmlplusplus")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wjz591rjlgbah7dcq8i0yn0zw9d62b7g6r0pppx81ic0cx8n8ga"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-documentation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook"))
- (xsldoc (string-append (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl))))
- (substitute* '("examples/dom_xpath/example.xml"
- "docs/manual/libxml++_without_code.xml")
- (("http://.*/docbookx\\.dtd")
- (string-append xmldoc "/docbookx.dtd")))
- (setenv "SGML_CATALOG_FILES"
- (string-append xmldoc "/catalog.xml"))
- (substitute* "docs/manual/docbook-customisation.xsl"
- (("http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl")
- (string-append xsldoc "/html/chunk.xsl"))))
- #t)))))
- (propagated-inputs
- `(("libxml2" ,libxml2)))
- (inputs
- `(("glibmm" ,glibmm-2.64)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("doxygen" ,doxygen)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("graphviz" ,graphviz) ; for dot
- ("libtool" ,libtool)
- ("libxslt" ,libxslt)
- ("mm-common" ,mm-common)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)))
- (home-page "https://github.com/libxmlplusplus/libxmlplusplus/")
- (synopsis "C++ bindings for libxml2")
- (description
- "libxml++ (a.k.a. libxmlplusplus) provides a C++ interface to XML files.
-It uses libxml2 to access the XML files.")
- (license license:lgpl2.1+)))
-
-;; This is the last release providing the 2.6 API, hence the name.
-;; This is needed by tascam-gtk
-(define-public libxmlplusplus-2.6
- (package
- (inherit libxmlplusplus)
- (name "libxmlplusplus")
- (version "2.40.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libxmlplusplus/libxmlplusplus")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0gbfi4l88w828gmyc9br11l003ylyi4vigp5d1kfgsn0k4cig3y9"))))))
-
(define-public python-libxml2
(package/inherit libxml2
(name "python-libxml2")