summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-06-19 15:36:00 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-02 17:17:37 +0200
commit536577390f96d83a3dcf11e4946d408eaa0015eb (patch)
tree4cc156ca98719abeeefa78e7c2bbe54722b98e48 /gnu/packages/xml.scm
parent1941055aa7130604fdbcb677222ca7f9ef970f61 (diff)
downloadguix-patches-536577390f96d83a3dcf11e4946d408eaa0015eb.tar
guix-patches-536577390f96d83a3dcf11e4946d408eaa0015eb.tar.gz
gnu: Add xlsxio
* gnu/packages/xml.scm: (xlsxio): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 959745e4f7..4fb3dc6985 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2018 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
(define-module (gnu packages xml)
#:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages autotools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1427,6 +1429,42 @@ generating, manipulating, and validating XML documents using the DOM, SAX, and
SAX2 APIs.")
(license license:asl2.0)))
+(define-public xlsxio
+ (package
+ (name "xlsxio")
+ (version "0.2.26")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brechtsanders/xlsxio")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j8jral3yc2aib2ykp527lyb62a1d9p7qmfbszy7iy3s65pkma9b"))))
+ (native-inputs
+ `(("expat" ,expat)
+ ("make" ,gnu-make)
+ ("minizip" ,minizip)
+ ("which" ,which)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "install"
+ (string-append
+ "PREFIX=" (assoc-ref outputs "out"))))))))
+ (synopsis "C library for reading and writing .xlsx files")
+ (description "XLSX I/O aims to provide a C library for reading and writing
+.xlsx files. The .xlsx file format is the native format used by Microsoft(R)
+Excel(TM) since version 2007.")
+ (home-page "https://github.com/brechtsanders/xlsxio")
+ (license license:expat)))
+
(define-public java-simple-xml
(package
(name "java-simple-xml")