summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
commit52665d2b6bd709ba46c1e364a6d6164f5f4824ff (patch)
tree55fd79b3939c08f6f6e9fe383f0df5e4caa82b57 /gnu/packages/xml.scm
parent584d08c5c98cb1893e4f44bd1c4191f405b13f01 (diff)
parent0a83339bb1429332ee889e9a976aa214ae2ac0db (diff)
downloadguix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar
guix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index da3964b961..b93ca0077b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2044,14 +2044,14 @@ modular implementation of XML-RPC for C and C++.")
(define-public python-elementpath
(package
(name "python-elementpath")
- (version "1.3.3")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "elementpath" version))
(sha256
(base32
- "1rb8892zli74wk1c4hyg77ja9wglq9hplgxwak1rmj3s9p6xnf0p"))))
+ "15h7d41v48q31hzjay7qzixdv531hnga3h35hksk7x52pgqcrkz7"))))
(build-system python-build-system)
(home-page
"https://github.com/sissaschool/elementpath")
@@ -2098,13 +2098,17 @@ libxml2 and libxslt.")
(define-public python-xmlschema
(package
(name "python-xmlschema")
- (version "1.0.18")
+ (version "1.1.0")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "xmlschema" version))
+ ;; Unit tests are not distributed with the PyPI archive.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sissaschool/xmlschema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1inwqwr7d3qah9xf9rfzkpva433jpr4n7n43zybf2gdpz4q1g0ry"))))
+ "1h8321jb6q3dhlh3608y3f3sbbzfd3jg1psyirxkrm4w5xs3lbvy"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -2116,7 +2120,7 @@ libxml2 and libxslt.")
(setenv "PYTHONPATH"
(string-append "./build/lib:"
(getenv "PYTHONPATH")))
- (invoke "python" "xmlschema/tests/test_all.py"))
+ (invoke "python" "-m" "unittest" "-v"))
(format #t "test suite not run~%"))
#t)))))
(native-inputs