summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-14 16:30:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 16:30:19 +0100
commit19008a22d18e772062952034c58a15ed341df3b5 (patch)
tree3a7fb9b4abe5cbac3f7edd5d5c76abd993fad255 /gnu/packages/xml.scm
parent520ae432d446010ed6a5233c8abfda88a945926c (diff)
parentc958c31caefb20c32cf89caea7d4668d7021a92b (diff)
downloadguix-patches-19008a22d18e772062952034c58a15ed341df3b5.tar
guix-patches-19008a22d18e772062952034c58a15ed341df3b5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b25b06cf50..cafdd7e656 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -867,14 +867,16 @@ the form of functions.")
(method url-fetch)
(uri (string-append "https://github.com/zeux/pugixml/releases/download/v"
version "/pugixml-" version ".tar.gz"))
+ (patches (search-patches "pugixml-versioned-libdir.patch"))
(sha256
(base32
"19nv3zhik3djp4blc4vrjwrl8dfhzmal8b21sq7y907nhddx6mni"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DCMAKE_CXX_FLAGS=-shared -fPIC"
- "-DCMAKE_C_FLAGS=-shared -fPIC")
- #:tests? #f)) ; no tests
+ `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+ #:tests? #f)) ;no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(home-page "https://pugixml.org")
(synopsis "Light-weight, simple and fast XML parser for C++ with XPath support")
(description