summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-04 16:38:10 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-05 10:37:59 +0800
commit9d44ab95a600a481e4e88ed3ad41cc1ae8628713 (patch)
tree7e0abe88afa8fcc25769e1e1aaf344d7c16809e1 /gnu/packages/xiph.scm
parent68e3c29d202cb7201a69269159cac49527e62938 (diff)
downloadguix-patches-9d44ab95a600a481e4e88ed3ad41cc1ae8628713.tar
guix-patches-9d44ab95a600a481e4e88ed3ad41cc1ae8628713.tar.gz
gnu: Add libshout.
* gnu/packages/xiph.scm (libshout): New varibale.
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 526a559724..dff76cacf5 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -372,3 +372,31 @@ create an Internet radio station or a privately running jukebox and many
things in between.")
(home-page "http://icecast.org/")
(license license:gpl2)))
+
+(define-public libshout
+ (package
+ (name "libshout")
+ (version "2.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://downloads.xiph.org/releases/libshout/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0vlj4dxfxg06xhvv0z2zjjlrjh5di2m28w7v16zcygsy99mmyg6g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; shout.pc refers to all these.
+ `(("libtheora" ,libtheora)
+ ("libvorbis" ,libvorbis)
+ ("speex" ,speex)))
+ (home-page "http://www.icecast.org/")
+ (synopsis "Audio streaming library for icecast encoders")
+ (description
+ "Libshout is a library for communicating with and sending data to an
+icecast server. It handles the socket connection, the timing of the data,
+and prevents bad data from getting to the icecast server.")
+ (license license:gpl2+)))