summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-07 17:43:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-07 17:43:20 +0100
commit6d15516dc6ffca3622ff49179c5c7c360c11b54b (patch)
treed235b60e0605fd3aace9c3357a20658dac3e3d85 /gnu/packages/xiph.scm
parent0ed75a5f068541339bc1db6271796a3d382bb681 (diff)
parent982eff9e841f3539e4ecf93669435a290bfde571 (diff)
downloadguix-patches-6d15516dc6ffca3622ff49179c5c7c360c11b54b.tar
guix-patches-6d15516dc6ffca3622ff49179c5c7c360c11b54b.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index d7530f0392..edb690b5ff 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -69,6 +69,8 @@
(base32
"1zlk33vxvxr0l9lhkbhkdwvylw96d2n0fnd3d8dl031hph9bqqy1"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(synopsis "Library for manipulating the ogg multimedia format")
(description
"The libogg library allows to manipulate the ogg multimedia container
@@ -93,7 +95,8 @@ periodic timestamps for seeking.")
"05dlzjkdpv46zb837wysxqyn8l636x3dw8v8ymlrwz2fg1dbn05g"))))
(build-system gnu-build-system)
(propagated-inputs `(("libogg" ,libogg)))
- (arguments `(#:configure-flags '("LDFLAGS=-lm")
+ (arguments `(#:configure-flags '("LDFLAGS=-lm"
+ "--disable-static")
#:parallel-tests? #f))
(synopsis "Library implementing the vorbis audio format")
(description
@@ -119,6 +122,8 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
"0q8wark9ribij57dciym5vdikg2464p8q2mgqvfb78ksjh4s8vgk"))
(patches (search-patches "libtheora-config-guess.patch"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs `(("libvorbis" ,libvorbis)))
;; The .pc files refer to libogg.
(propagated-inputs `(("libogg" ,libogg)))
@@ -174,7 +179,8 @@ stereo encoding, and voice activity detection.")
"0wa7sqpk3x61zz99m7lwkgr6yv62ml6lfgs5xja65vlvdzy44838"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '(,@(if (string=? "aarch64-linux"
+ `(#:configure-flags '("--disable-static"
+ ,@(if (string=? "aarch64-linux"
(%current-system))
'("--enable-neon=no") ; neon defaults to armv7-a
'()))))
@@ -352,6 +358,8 @@ ogginfo, to obtain information (tags, bitrate, length, etc.) about
(base32
"17gz8kxs4i7icsc1gj713gadiapyklynlwqlf0ai98dj4lg8xdb5"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(synopsis "Versatile audio codec")
(description
"Opus is a totally open, royalty-free, highly versatile audio codec. Opus