summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-04 14:39:09 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-24 16:31:03 +0100
commit60541df3c4ace9ce13590f9e98b0fdd9b4435c1a (patch)
treeb052c510abbc788075c1039b3f87d4fa81a17713 /gnu/packages/xiph.scm
parent6b01be8b04c95fed164fd6b154a2fa58548e4d73 (diff)
downloadguix-patches-60541df3c4ace9ce13590f9e98b0fdd9b4435c1a.tar
guix-patches-60541df3c4ace9ce13590f9e98b0fdd9b4435c1a.tar.gz
gnu: Add xiph-rnnoise.
* gnu/packages/xiph.scm (xiph-rnnoise): New variable.
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index ccd99de7c6..1159246a67 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -498,3 +498,36 @@ things in between.")
icecast server. It handles the socket connection, the timing of the data,
and prevents bad data from getting to the icecast server.")
(license license:gpl2+)))
+
+(define-public xiph-rnnoise
+ ;; No upstream release
+ (let ((commit "7f449bf8bd3b933891d12c30112268c4090e4d59")
+ (revision "0"))
+ (package
+ (name "rnnoise")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.xiph.org/xiph/rnnoise")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y8jdvxd9namw4f9hcmcmm2q0f32mnhfyjap8906hl308cws3rkj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://gitlab.xiph.org/xiph/rnnoise")
+ (synopsis "Real-time noise suppression")
+ (description "RNNoise is a noise suppression library based on a recurrent
+neural network. The algorithm is described in Jean-Marc Valin's paper
+@cite{A Hybrid DSP/Deep Learning Approach to Real-Time Full-Band Speech
+Enhancement}.")
+ (license license:bsd-3)
+ (properties
+ ;; There's no public release and a conflicting package, so hide it for
+ ;; now.
+ `((hidden? . #t))))))