summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-26 10:05:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-26 23:47:37 +0200
commit01229cbe16802616880ead1742e27cb120480e3c (patch)
tree969c7606c14774b38f4eeb0d0c77afbc7e310d1e /gnu/packages/xiph.scm
parent727bec13a35049f5f819a6f22d93e38aa44220b2 (diff)
downloadguix-patches-01229cbe16802616880ead1742e27cb120480e3c.tar
guix-patches-01229cbe16802616880ead1742e27cb120480e3c.tar.gz
gnu: Add speexdsp.
* gnu/packages/xiph.scm (speexdsp): New variable. Export it.
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 5ad504604a..7b02980159 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
libvorbis
libtheora
speex
+ speexdsp
ao
flac
libkate
@@ -149,6 +151,26 @@ stereo encoding, and voice activity detection.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
+(define speexdsp
+ (package
+ (name "speexdsp")
+ (version "1.2rc3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://downloads.xiph.org/releases/speex/"
+ "speexdsp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wcjyrnwlkayb20zdhp48y260rfyzg925qpjpljd5x9r01h8irja"))))
+ (build-system gnu-build-system)
+ (home-page "https://speex.org/")
+ (synopsis "Speex processing library")
+ (description
+ "SpeexDSP is a @dfn{DSP} (Digital Signal Processing) library based on
+work from the @code{speex} codec.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define ao
(package
(name "ao")