summaryrefslogtreecommitdiff
path: root/gnu/packages/xfig.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-02 11:02:24 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-02 15:06:02 +0100
commit63b31b567e4716e6dacb764847f5cdebcb9ed8e5 (patch)
treef6a38669aaf65e5488ca30fb9db7b02cb43c0e28 /gnu/packages/xfig.scm
parent04bbd07218b5e67068219b90ff99df9580c47c0e (diff)
downloadguix-patches-63b31b567e4716e6dacb764847f5cdebcb9ed8e5.tar
guix-patches-63b31b567e4716e6dacb764847f5cdebcb9ed8e5.tar.gz
gnu: xfig: Don't ignore 'xmkmf' exit code.
Suggested by Mike Gerwitz <mtg@gnu.org>. * gnu/packages/xfig.scm (xfig)[arguments]: Use 'invoke' when invoking 'xmkmf'.
Diffstat (limited to 'gnu/packages/xfig.scm')
-rw-r--r--gnu/packages/xfig.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/xfig.scm b/gnu/packages/xfig.scm
index 64ca57028f..e51558e0be 100644
--- a/gnu/packages/xfig.scm
+++ b/gnu/packages/xfig.scm
@@ -90,7 +90,7 @@
(("XCOMM USEINLINE") "USEINLINE"))
;; The -a argument is required in order to pick up the correct paths
;; to several X header files.
- (zero? (system* "xmkmf" "-a"))
+ (invoke "xmkmf" "-a")
;; Reset some variables that are inherited from imake templates
(substitute* "Makefile"
;; These imake variables somehow remain undefined