summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:33 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:29:44 +0200
commitfa6a9d9863c111f84eaca3a56af93a3ae2c9bc9a (patch)
tree59f48c387629deb1c7f2040af7a8f25dcd5a6bf3 /gnu/packages/xfce.scm
parent18af33827bb446b09605d29b2e8ea0e3106d6da4 (diff)
downloadguix-patches-fa6a9d9863c111f84eaca3a56af93a3ae2c9bc9a.tar
guix-patches-fa6a9d9863c111f84eaca3a56af93a3ae2c9bc9a.tar.gz
gnu: Add xfce4-diskperf-plugin.
* gnu/packages/xfce.scm (xfce4-diskperf-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 510fa78260..d4c2cb701a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1372,6 +1372,33 @@ precedence rules, and the following functions and common constants.")
governor and frequencies supported and used by your system.")
(license gpl2+)))
+(define-public xfce4-diskperf-plugin
+ (package
+ (name "xfce4-diskperf-plugin")
+ (version "2.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-diskperf-plugin/"
+ (version-major+minor version)
+ "/xfce4-diskperf-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0i4nrsvwcn15g5gmnba9p07sad3c96x517l2lybdw8jqv91rhbpx"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin")
+ (synopsis "Display disk performance in the Xfce panel")
+ (description "This Xfce panel plugin displays instant disk/partition
+performance (bytes transfered per second).")
+ (license gpl2+)))
+
(define-public xfce4-embed-plugin
(package
(name "xfce4-embed-plugin")