summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 21:29:46 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 21:29:46 +0200
commitf03426420497cd9839f5fb3cb547dbecd8d6053b (patch)
tree220cdbab5b58b27c63d2df3ee711ad4bfdda074b /gnu/packages/xfce.scm
parent3cf1afb7e7249992b2db2f4f00899fd22237e89a (diff)
parent069399ee9dbf75b7c89583f03346a63b2cfe4ac6 (diff)
downloadguix-patches-f03426420497cd9839f5fb3cb547dbecd8d6053b.tar
guix-patches-f03426420497cd9839f5fb3cb547dbecd8d6053b.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/bioinformatics.scm gnu/packages/django.scm gnu/packages/gtk.scm gnu/packages/llvm.scm gnu/packages/python-web.scm gnu/packages/python.scm gnu/packages/tex.scm guix/build-system/asdf.scm guix/build/emacs-build-system.scm guix/profiles.scm
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm63
1 files changed, 50 insertions, 13 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 40a3db528f..1ff348f9e6 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages calendar)
#:use-module (gnu packages cdrom)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -48,6 +50,7 @@
#:use-module (gnu packages inkscape)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages mate)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
#:use-module (gnu packages photo)
@@ -313,7 +316,7 @@ upstream occasionally.")
(define-public exo
(package
(name "exo")
- (version "4.16.1")
+ (version "4.16.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -321,7 +324,7 @@ upstream occasionally.")
"exo-" version ".tar.bz2"))
(sha256
(base32
- "0fxm2aczzbi0z4y6x24934964y9jg4cl4frvlnjc5zqmccjsr3aj"))))
+ "17cybaml221jnw99aig3zajg2kbnn87p5sycj68wpwgvd99zb2af"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -413,7 +416,7 @@ management D-Bus specification.")
(define-public xfce4-panel
(package
(name "xfce4-panel")
- (version "4.16.2")
+ (version "4.16.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -421,7 +424,7 @@ management D-Bus specification.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1kxm905z6m0mvnki7qxwz638kfa93lvy5xv3qfp8sc8ldxp1cd46"))
+ "14p0y6d3frphv67vsvnx6c1l4m82c1wwsk3kkg155nknibnyld2r"))
(patches (search-patches "xfce4-panel-plugins.patch"))))
(build-system gnu-build-system)
(arguments
@@ -492,7 +495,7 @@ applications menu, workspace switcher and more.")
(define-public xfce4-clipman-plugin
(package
(name "xfce4-clipman-plugin")
- (version "1.6.1")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -500,7 +503,7 @@ applications menu, workspace switcher and more.")
"xfce4-clipman-plugin-" version ".tar.bz2"))
(sha256
(base32
- "1d6fxdzy9b511hqcyj7825fx67q6zqk6cln4g3x9d498jrvk3s5k"))))
+ "1f4rjdvyplfkrdqg9179chzxx18k3lx29674j28piccgyvk5z2mb"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -704,7 +707,14 @@ your system in categories, so you can quickly find and launch them.")
(list (string-append "--with-xsession-prefix=" %output))
;; Disable icon cache update.
#:make-flags
- '("gtk_update_icon_cache=true")))
+ '("gtk_update_icon_cache=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-xflock
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xset (assoc-ref inputs "xset")))
+ (substitute* "scripts/xflock4"
+ (("xset") (string-append xset "/bin/xset")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
@@ -714,7 +724,8 @@ your system in categories, so you can quickly find and launch them.")
("polkit" ,polkit)
("libsm" ,libsm)
("libwnck" ,libwnck)
- ("libxfce4ui" ,libxfce4ui)))
+ ("libxfce4ui" ,libxfce4ui)
+ ("xset" ,xset)))
(home-page "https://www.xfce.org/")
(synopsis "Xfce session manager")
(description
@@ -725,7 +736,7 @@ allows you to shut down the computer from Xfce.")
(define-public xfce4-settings
(package
(name "xfce4-settings")
- (version "4.16.0")
+ (version "4.16.1")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -733,7 +744,7 @@ allows you to shut down the computer from Xfce.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1hnx88a8xmi38mdf5gxdvx7n8yax1vzah8hy8g37bijlqx7l18b7"))
+ "1iim6sbh58hjwdmwsdlbh9bdnrs2k98crapv3kdhwkd3gazf2a5v"))
(patches (search-patches "xfce4-settings-defaults.patch"))))
(build-system gnu-build-system)
(arguments
@@ -755,6 +766,10 @@ allows you to shut down the computer from Xfce.")
("upower" ,upower) ;; TODO needs upower-glib
("python" ,python) ;; for xfce4-compose-mail
("xf86-input-libinput" ,xf86-input-libinput)))
+ (propagated-inputs
+ ;; Some operations, such as changing icon themes, require these schemas
+ ;; to be in the search path.
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(home-page "https://www.xfce.org/")
(synopsis "Xfce settings manager")
(description
@@ -765,7 +780,7 @@ like appearance, display, keyboard and mouse settings.")
(define-public thunar
(package
(name "thunar")
- (version "4.16.6")
+ (version "4.16.8")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -773,7 +788,7 @@ like appearance, display, keyboard and mouse settings.")
"thunar-" version ".tar.bz2"))
(sha256
(base32
- "1dq238m2bh938gpb058cr2xmhy6f3qkyyya9l0ya95kiwqzislyb"))))
+ "159ircj0mahx54fqsr3l3ynk690zlpc6ar5pnyhhpk90s8la5303"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -892,7 +907,8 @@ on the screen.")
(copy-file "/tmp/final.jpg" image))
'(;; "backgrounds/xfce-blue.jpg"
"backgrounds/xfce-stripes.png"
- "backgrounds/xfce-teal.jpg"))
+ "backgrounds/xfce-teal.jpg"
+ "backgrounds/xfce-verticals.png"))
#t)))
#:disallowed-references (,inkscape ,imagemagick)))
@@ -948,6 +964,23 @@ menubar and the window decorations are hidden) that helps you to save space
on your desktop.")
(license gpl2+)))
+(define-public mate-polkit-for-xfce
+ (package/inherit mate-polkit
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'patch-desktop
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((common (string-append
+ (assoc-ref outputs "out") "/etc/xdg/autostart/"
+ "polkit-mate-authentication-agent-"))
+ (old (string-append common "1.desktop"))
+ (new (string-append common "for-xfce-1.desktop")))
+ (substitute* old (("MATE;") "XFCE;"))
+ ;; To avoid a conflict if both MATE and XFCE are installed.
+ (rename-file old new)))))))
+ (properties `((hidden? . #t)))))
+
(define-public xfce
(package
(name "xfce")
@@ -971,6 +1004,7 @@ on your desktop.")
("gnome-icon-theme" ,gnome-icon-theme)
("gtk-xfce-engine" ,gtk-xfce-engine)
("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("mate-polkit-for-xfce" ,mate-polkit-for-xfce)
("ristretto" ,ristretto)
("shared-mime-info" ,shared-mime-info)
("thunar" ,thunar)
@@ -990,6 +1024,9 @@ on your desktop.")
("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
("xfce4-xkb-plugin" ,xfce4-xkb-plugin)))
+ (propagated-inputs
+ ;; Default font that applications such as IceCat require.
+ `(("font-dejavu" ,font-dejavu)))
(native-search-paths
;; For finding panel plugins.
(package-native-search-paths xfce4-panel))