summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:22 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:26:45 +0200
commitc6927c08bde76d83758674747ca718cf543772aa (patch)
tree339f37b47a406e14a8b3ea286e02d652f919f355 /gnu/packages/xfce.scm
parentf800291e0809ab477e07df4fbd23216d451d8c58 (diff)
downloadguix-patches-c6927c08bde76d83758674747ca718cf543772aa.tar
guix-patches-c6927c08bde76d83758674747ca718cf543772aa.tar.gz
gnu: Add xfce4-verve-plugin.
* gnu/packages/xfce.scm (xfce4-verve-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 13d16def99..ec699a79df 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1230,6 +1230,40 @@ A plugin for the Xfce panel is also available.")
the volume using multimedia keys. It also provides volume change notifications.")
(license gpl3+)))
+(define-public xfce4-verve-plugin
+ (package
+ (name "xfce4-verve-plugin")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-verve-plugin/"
+ (version-major+minor version)
+ "/xfce4-verve-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ljcmgc8ixrbz134ggxbbh4zzdnp7mhi9ay6s5hgrz28djx10rcy"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin")
+ (synopsis "Command line for the Xfce panel")
+ (description "The Verve plugin provides a comfortable command line
+for the Xfce panel. It supports several features, such as:
+@itemize
+@item Opens URLs, e-mail addresses, directories, and programs
+@item Command history
+@item Auto-completion (including command history)
+@item Focus grabbing via D-BUS (so you can bind a shortcut to it)
+@item Custom input field width
+@end itemize")
+ (license gpl2+)))
+
(define-public xfce4-wavelan-plugin
(package
(name "xfce4-wavelan-plugin")