summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/xfce.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm48
1 files changed, 10 insertions, 38 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index fc09c65f2b..f27e7e6e49 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -413,7 +413,7 @@ management D-Bus specification.")
(define-public xfce4-panel
(package
(name "xfce4-panel")
- (version "4.16.1")
+ (version "4.16.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -421,7 +421,7 @@ management D-Bus specification.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "14arjxpvnxdl0a0ajifrmy2py3hv5qy4fykl52wdp4k5pv39n2gs"))
+ "1kxm905z6m0mvnki7qxwz638kfa93lvy5xv3qfp8sc8ldxp1cd46"))
(patches (search-patches "xfce4-panel-plugins.patch"))))
(build-system gnu-build-system)
(arguments
@@ -1206,7 +1206,7 @@ of data to either CD/DVD/BD.")
(define-public mousepad
(package
(name "mousepad")
- (version "0.5.2")
+ (version "0.5.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/apps/mousepad/"
@@ -1214,7 +1214,7 @@ of data to either CD/DVD/BD.")
version ".tar.bz2"))
(sha256
(base32
- "13pvisqhq5rjrkfdw635z600167920fxqzg1ngvismaf39iwbb9h"))))
+ "1a6a3x4h6aisjm59i0afx1w50035s76zjr4a6p9ja5bax6wqn877"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '(;; Use the GSettings keyfile backend rather than
@@ -1357,7 +1357,7 @@ A plugin for the Xfce panel is also available.")
(define-public xfce4-cpugraph-plugin
(package
(name "xfce4-cpugraph-plugin")
- (version "1.2.1")
+ (version "1.2.3")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -1366,7 +1366,7 @@ A plugin for the Xfce panel is also available.")
"/xfce4-cpugraph-plugin-" version ".tar.bz2"))
(sha256
(base32
- "0jljxyvxq4kmf5wz7wkq6wma4bq1qsnlv3lx6527lhcipnddynk1"))))
+ "13302psv0fzg2dsgadr8j6mb06k1bsa4zw6hxmb644vqlvcwq37v"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -1648,34 +1648,6 @@ The string can also contain markup to displayed an image, a bar, a
button and a personalized tooltip.")
(license gpl2+)))
-(define-public xfce4-kbdleds-plugin
- (package
- (name "xfce4-kbdleds-plugin")
- (version "0.0.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-kbdleds-plugin/"
- (version-major+minor version)
- "/xfce4-kbdleds-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "1k810asjjxwix1c7ixl7bqr97zc4j2mw7797gk49rjvv43bhla3d"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("gtk+-2" ,gtk+-2)
- ("libxfce4ui" ,libxfce4ui)
- ("xfce4-panel" ,xfce4-panel)))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin")
- (synopsis "Display keyboard LEDs in the Xfce panel")
- (description "This plugin shows the state of your keyboard LEDs:
-Caps, Scroll and Num Lock in Xfce panel.")
- (license gpl2+)))
-
(define-public xfce4-mailwatch-plugin
(package
(name "xfce4-mailwatch-plugin")
@@ -1972,7 +1944,7 @@ swap space and the system uptime in the Xfce4 panel.")
(define-public xfce4-time-out-plugin
(package
(name "xfce4-time-out-plugin")
- (version "1.1.1")
+ (version "1.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -1981,7 +1953,7 @@ swap space and the system uptime in the Xfce4 panel.")
"/xfce4-time-out-plugin-" version ".tar.bz2"))
(sha256
(base32
- "07d3vddzrl6p6kg3qs4rd8qk57ghf33sk9sh73gsx2hxfnwbwk8r"))))
+ "1m42kmi0x3xb0lzj2nd7q2r5y5r2viqcvxfpbg1aafzzjjkfpn1x"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -2091,7 +2063,7 @@ lan interface (signal state, signal quality, network name (SSID)).")
(define-public xfce4-weather-plugin
(package
(name "xfce4-weather-plugin")
- (version "0.10.2")
+ (version "0.11.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -2100,7 +2072,7 @@ lan interface (signal state, signal quality, network name (SSID)).")
"/xfce4-weather-plugin-" version ".tar.bz2"))
(sha256
(base32
- "1ik2qvmwylsz5vyz4np2y0mmd37s89xkayxi97490c4mj85pj5wh"))))
+ "1z2k24d599mxf5gqa35i3xmc3gk2yvqs80hxxpyw06yma6ljw973"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)