summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-10-22 00:06:41 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-28 00:44:10 +0200
commit6cf6dc111685b4bbbc5e92bd4e36e13ad3cdb926 (patch)
tree0ffa8270c8392cc27328bde1e5793abf9b84686d /gnu/packages/xfce.scm
parentbcc4aef0dbaaf3a66e11e0af30c88e60f8f9d4fb (diff)
downloadguix-patches-6cf6dc111685b4bbbc5e92bd4e36e13ad3cdb926.tar
guix-patches-6cf6dc111685b4bbbc5e92bd4e36e13ad3cdb926.tar.gz
gnu: Add xfce4-dev-tools
This is now needed to build newer lightdm-gtk-greeter versions * gnu/packages/xfce.scm (xfce4-dev-tools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c653b23a91..c279ac9355 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2130,3 +2130,28 @@ lan interface (signal state, signal quality, network name (SSID)).")
local weather in the panel, using forecast data provided by the
@uref{https://met.no, Norwegian Meteorological Institute}.")
(license gpl2+)))
+
+(define-public xfce4-dev-tools
+ (package
+ (name "xfce4-dev-tools")
+ (version "4.17.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/xfce/"
+ "xfce4-dev-tools/" (version-major+minor version) "/"
+ "xfce4-dev-tools-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1iwkqj96x2s7fk4srg1pymvsiwb2rn6vvhy6hrmnc3hl1vqw2d6k"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "https://docs.xfce.org/xfce/xfce4-dev-tools/")
+ (synopsis "Xfce developer tools")
+ (description
+ "The Xfce development tools are a collection of tools and macros for Xfce
+developers and people that want to build Xfce from Git In addition it contains
+the Xfce developer's handbook.")
+ (license gpl2+)))