summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-26 10:04:31 +0800
committerLudovic Courtès <ludo@gnu.org>2022-03-29 11:36:15 +0200
commit5cabe24e563c116e11ea25093aa248569c4c8aae (patch)
treedb72cb6c367699ec5d857439a37ea370fda026eb /gnu/packages/xfce.scm
parentddfebdab86178af7e434a73a6dd9fab733522245 (diff)
downloadguix-patches-5cabe24e563c116e11ea25093aa248569c4c8aae.tar
guix-patches-5cabe24e563c116e11ea25093aa248569c4c8aae.tar.gz
gnu: Add xfce4-dict.
* gnu/packages/xfce.scm (xfce4-dict): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bc19fc5250..90f7467cef 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -932,6 +932,35 @@ menubar and the window decorations are hidden) that helps you to save space
on your desktop.")
(license gpl2+)))
+(define-public xfce4-dict
+ (package
+ (name "xfce4-dict")
+ (version "0.8.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/apps/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1qriyvii50v8a8dx7aw6nlm888mf5cjrb9nwm3r0dcs2yzxzx1fb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list intltool pkg-config))
+ (inputs
+ (list libxfce4ui xfce4-panel))
+ (home-page "https://www.xfce.org/")
+ (synopsis "Dictionary of Xfce desktop")
+ (description
+ "Xfce4-dict allows you to search different kinds of dictionary services
+for words or phrases and shows you the result. Currently you can query a Dict
+server (RFC 2229), any online dictionary service by opening a web browser or
+search for words using the aspell/ispell program.
+
+xfce4-dict contains a stand-alone application called “xfce4-dict” and a panel
+plugin for the Xfce panel.")
+ (license gpl2+)))
+
(define-public xfdashboard
(package
(name "xfdashboard")