summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-26 07:01:25 +0800
committerLudovic Courtès <ludo@gnu.org>2022-04-04 22:58:03 +0200
commit4b451813f7c5677086772e29a66a8265ec0ca2c7 (patch)
treeda43860527ade778f81a86cecbb5f607cdc8071e /gnu/packages/xfce.scm
parente692dc632cbb0e6d21ed6f09f4c7f52391802cfb (diff)
downloadguix-patches-4b451813f7c5677086772e29a66a8265ec0ca2c7.tar
guix-patches-4b451813f7c5677086772e29a66a8265ec0ca2c7.tar.gz
gnu: Add parole.
* gnu/packages/xfce.scm (parole): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bf668fc9cd..44b6c34b29 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -36,6 +36,7 @@
#:use-module (gnu artwork)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages calendar)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages fonts)
@@ -904,6 +905,52 @@ remote file systems using GIO/GVfs. It allows you to quickly connect/mount
local and remote file systems and manage bookmarks of such.")
(license gpl2))) ;version 2 only
+(define-public parole
+ (package
+ (name "parole")
+ (version "4.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/apps/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1rx7apylqb7mf1dl0sswj1630fca3ddk4x1gcdmlv5ykrkc5lc0d"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list (string-append "CPPFLAGS=-I"
+ #$(this-package-input "gst-plugins-base")
+ "/include/gstreamer-1.0"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-parole
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append #$output "/bin/parole")
+ #:sh (search-input-file inputs "bin/bash")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))))))
+ (native-inputs
+ (list pkg-config intltool gobject-introspection))
+ (inputs
+ (list bash-minimal ;for 'wrap-program'
+ dbus-glib
+ (list glib "bin")
+ gstreamer
+ gst-plugins-base
+ gst-plugins-good
+ libnotify
+ libxfce4ui
+ libxfce4util))
+ (home-page "https://www.xfce.org/")
+ (synopsis "Media player based on the GStreamer framework")
+ (description "Parole is a modern simple media player based on the
+GStreamer framework and written to fit well in the Xfce desktop. Parole
+features playback of local media files, DVD/CD and live streams.")
+ (license gpl2))) ;version 2 only
+
(define-public xfce4-terminal
(package
(name "xfce4-terminal")