summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:25 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:27:29 +0200
commit2ebc7316ce757cef78098c26e8ed91d688fdc522 (patch)
tree360982c7480978e50fce23a6b7d185551332d0fc /gnu/packages/xfce.scm
parent820a0869eaf662c60451afcee7cdc7e2574ed686 (diff)
downloadguix-patches-2ebc7316ce757cef78098c26e8ed91d688fdc522.tar
guix-patches-2ebc7316ce757cef78098c26e8ed91d688fdc522.tar.gz
gnu: Add xfce4-smartbookmark-plugin.
* gnu/packages/xfce.scm (xfce4-smartbookmark-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index cae32aeb09..25d2b05124 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1230,6 +1230,34 @@ A plugin for the Xfce panel is also available.")
the volume using multimedia keys. It also provides volume change notifications.")
(license gpl3+)))
+(define-public xfce4-smartbookmark-plugin
+ (package
+ (name "xfce4-smartbookmark-plugin")
+ (version "0.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-smartbookmark-plugin/"
+ (version-major+minor version)
+ "/xfce4-smartbookmark-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "001nf2bqly8vm868qvafzgihc9463c488mkim24iw9g2s9ygna1y"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin")
+ (synopsis "Perform custom searches in your browser from the Xfce panel")
+ (description "This plugin allows you to send search requests
+directly to your browser, such that you can search through your
+favorite search engine or bug tracker right from the Xfce panel.")
+ (license gpl2+)))
+
(define-public xfce4-systemload-plugin
(package
(name "xfce4-systemload-plugin")