summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorJosh Holland <josh@inv.alid.pw>2020-05-29 10:14:39 +0100
committerMarius Bakke <marius@gnu.org>2020-05-30 16:41:40 +0200
commite552fca96ce249b253f522e51e8f8bd769d166cf (patch)
treee5a430a6f0d22ea91ebc2885619f70b08b1455f2 /gnu/packages/xdisorg.scm
parentf55152cec4d200d59bc503c0442b96827dd8c0e2 (diff)
downloadguix-patches-e552fca96ce249b253f522e51e8f8bd769d166cf.tar
guix-patches-e552fca96ce249b253f522e51e8f8bd769d166cf.tar.gz
gnu: bemenu: Update to 0.4.1.
* gnu/packages/xdisorg.scm (bemenu): Update to 0.4.1. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 1325fbc821..3c98836102 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Kyle Andrews <kyle.c.andrews@gmail.com>
-;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
+;;; Copyright © 2019, 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 David Wilson <david@daviwil.com>
@@ -215,7 +215,7 @@ used to further tweak the behaviour of the different profiles.")
(define-public bemenu
(package
(name "bemenu")
- (version "0.2.0")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
@@ -224,10 +224,18 @@ used to further tweak the behaviour of the different profiles.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0piax49az5kp96r1g6dcgj87fi6p4jl286wlkxsdvljzpkn8q6gv"))))
- (build-system cmake-build-system)
+ (base32 "1fjcs9d3533ay3nz79cx3c0lmy2chgragr2lhsy0xl2ckr0iins0"))))
+ (build-system gnu-build-system)
(arguments
- '(#:configure-flags '("-DBEMENU_WAYLAND_RENDERER=ON")))
+ '(#:tests? #f
+ #:make-flags (list "CC=gcc"
+ "CFLAGS=-O2 -fPIC"
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
(inputs
`(("cairo" ,cairo)
("libx11" ,libx11)
@@ -246,7 +254,7 @@ used to further tweak the behaviour of the different profiles.")
"bemenu is a dynamic menu which allows the user to flexibly select from a
list of options (usually programs to launch). It renders the menu graphically
with X11 or Wayland, or in a text terminal with ncurses.")
- (license (list license:gpl3+ ; client program[s] and other sources
+ (license (list license:gpl3+ ; client program[s] and other sources
license:lgpl3+)))) ; library and bindings
(define-public copyq