summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 16:30:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 19:23:50 +0200
commitddec076b963a80056fc5af3f0c74dd8870ae491e (patch)
treed7f021a6a3f93c4094bd704d0e3620e0fd608830 /gnu/packages/xdisorg.scm
parent328fac47890ad63d1f92c9fd7ed89f8f5f92b336 (diff)
downloadguix-patches-ddec076b963a80056fc5af3f0c74dd8870ae491e.tar
guix-patches-ddec076b963a80056fc5af3f0c74dd8870ae491e.tar.gz
gnu: sx: Don't propagate xauth.
* gnu/packages/xdisorg.scm (sx)[arguments]: Patch sx to refer to xauth. [propagated-inputs]: Move xauth from here… [inputs]: …to here.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9646f55b99..68f856f81f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2869,8 +2869,13 @@ and execute @file{.desktop} files of the Application type.")
(list (string-append "PREFIX=" out)))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'refer-to-xauth
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "sx"
+ (("\\bxauth\\b" command)
+ (string-append (assoc-ref inputs "xauth") "/bin/" command)))))
(delete 'configure)))) ; no configure script
- (propagated-inputs
+ (inputs
`(("xauth" ,xauth)))
(home-page "https://github.com/Earnestly/sx")
(synopsis "Start an xorg server")