summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-23 22:57:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-23 22:57:16 +0100
commitdb0e9fe42c419c8c8010dbad6080ed66028c03ec (patch)
tree514a0d8fe5465db9a950ac20579e5d3e37bc385b /gnu/packages/xdisorg.scm
parent43190ac64c5181841d68beade4d19e792f4f38a2 (diff)
parent82a2bd3a4ee09c04b51b948f1e952402d6a26f88 (diff)
downloadguix-patches-db0e9fe42c419c8c8010dbad6080ed66028c03ec.tar
guix-patches-db0e9fe42c419c8c8010dbad6080ed66028c03ec.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e79404ca7a..a9113923dd 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1895,7 +1895,7 @@ temperature of the screen.")
(home-page "https://github.com/google/xsecurelock")
(synopsis "X11 screen lock utility with the primary goal of security")
(description "@code{xsecurelock} is an X11 screen locker which uses
-a modular design to avoid the usual pitfalls of screen locking utility design.
+a modular design to avoid the usual pitfalls of screen locking utility design.
As a consequence of the modular design, the usual screen locker service
shouldn't be used with @code{xsecurelock}. Instead, you need to add a helper
@@ -1960,7 +1960,7 @@ The cutbuffer and clipboard selection are always synchronized.")
(define-public jgmenu
(package
(name "jgmenu")
- (version "3.5")
+ (version "4.0.1")
(source
(origin
(method git-fetch)
@@ -1970,34 +1970,35 @@ The cutbuffer and clipboard selection are always synchronized.")
(file-name (git-file-name name version))
(sha256
(base32
- "0q0m3sskgmjv28gzvjkphgg3yhwzc9w9fj9i342pibb50impjazy"))))
+ "1q0rpg2d96sn3rrdi8m7bngnxxqyxilpjxi7skiw4gvpiv1akxjp"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)
+ `(("cppcheck" ,cppcheck)
+ ("perl" ,perl)
("pkg-config" ,pkg-config)))
(inputs
`(("cairo" ,cairo)
+ ("glib" ,glib)
("librsvg" ,librsvg)
("libx11" ,libx11)
("libxml2" ,libxml2)
("libxrandr" ,libxrandr)
- ("pango" ,pango)
- ("python" ,python)))
+ ("pango" ,pango)))
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((python (assoc-ref inputs "python")))
- (substitute* "src/jgmenu-pmenu.py"
- (("#!/usr/bin/env python3")
- (string-append "#!" python "/bin/python3")))
- #t)))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "prefix" out)
- (setenv "CC" "gcc")
- #t))))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "scripts/cppcheck-wrapper.sh"
+ (("--library=/usr/share/cppcheck/cfg/gnu\\.cfg")
+ ""))
+ #t))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "CC" "gcc")
+ (invoke "./configure"
+ (string-append "--prefix=" (assoc-ref outputs "out")))
+ #t)))))
(synopsis "Simple X11 menu")
(description
"This is a simple menu for X11 designed for scripting and tweaking. It