summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 20:04:30 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-04 22:34:33 +0200
commita4e38cc2163e3881834887bdd68a79dcf9abfcf8 (patch)
tree70d75f03c500d6404e90b52ad6801bf33b4322cb /gnu/packages/xdisorg.scm
parent0758ee800277ae0916b894e7d20b9a4a14944130 (diff)
downloadguix-patches-a4e38cc2163e3881834887bdd68a79dcf9abfcf8.tar
guix-patches-a4e38cc2163e3881834887bdd68a79dcf9abfcf8.tar.gz
gnu: clipmenu: Set #:guile argument of 'wrap-script'.
* gnu/packages/xdisorg.scm (clipmenu)[arguments]<#:phases>{wrap-script}: Set #:guile argument of ‘wrap-script’. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index de2cba8e57..d339851f51 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2555,10 +2555,12 @@ tools to complement clipnotify.")
(gawk (assoc-ref inputs "gawk"))
(util-linux (assoc-ref inputs "util-linux"))
(xdotool (assoc-ref inputs "xdotool"))
- (xsel (assoc-ref inputs "xsel")))
+ (xsel (assoc-ref inputs "xsel"))
+ (guile (search-input-file inputs "bin/guile")))
(for-each
(lambda (prog)
(wrap-script (string-append out "/bin/" prog)
+ #:guile guile
`("PATH" ":" prefix
,(map (lambda (dir)
(string-append dir "/bin"))