summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorB. Wilson <elaexuotee@wilsonb.com>2020-11-22 16:02:13 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-24 13:48:15 +0100
commit993af4a60f4a70847224ea7e7d07d4bc714a668a (patch)
treee4d3f30df7ed776229cd4025bc2a63fc2d325e76 /gnu/packages/xdisorg.scm
parent8f0f29fcb01e056bb1e316303ca1ea90da065dce (diff)
downloadguix-patches-993af4a60f4a70847224ea7e7d07d4bc714a668a.tar
guix-patches-993af4a60f4a70847224ea7e7d07d4bc714a668a.tar.gz
gnu: Add xtitle.
gnu/packages/xdisorg.scm(xtitle): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 430b5ac770..e4edcfb177 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -110,6 +111,38 @@
;; packages outside the x.org system proper
+(define-public xtitle
+ (package
+ (name "xtitle")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/baskerville/xtitle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f5070k2bwarghl1vq886pl52xck1x5p7x3qhlfchsc2y3dcqms9"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libxcb" ,libxcb)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-wm" ,xcb-util-wm)))
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/baskerville/xtitle")
+ (synopsis "Output X window titles")
+ (description
+ "If arguments are given, @code{xtitle} outputs the title of each
+specified window, otherwise it outputs the title of the active window. With
+@emph{snoop} mode on, it continuously monitors the specified windows and
+outputs when titles change.")
+ (license license:unlicense)))
+
(define-public arandr
(package
(name "arandr")