summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 23:16:55 +0100
commit8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f (patch)
treeadc5d29e9c2dcda5befa0ca81f1af8df23294947 /gnu/packages/xdisorg.scm
parent2f33a7321e5e37d37f57c229c8079cb4ffd10834 (diff)
parent3374e9207f5244c20402a3c5513fe562140fef47 (diff)
downloadguix-patches-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar
guix-patches-8c14f7f8a7ab0722bf4c9f92fd28ae85514d564f.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 40e98e3ffc..c0333fbc82 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
-;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
@@ -179,7 +179,7 @@ program.")
"install_manpage"
"install_bash_completion"
"install_launcher"))))))
- (synopsis "Auto-detect connected displays and load appropiate setup")
+ (synopsis "Auto-detect connected displays and load appropriate setup")
(description "Autorandr wraps around xrandr to help with X11
multi-screen configuration management. It allows the user to create profiles
for various multi-screen setups. Autorandr automatically detects the profiles
@@ -391,21 +391,24 @@ rasterisation.")
(base32
"08yimlp6jir1rs5ajgdx74xa5qdzcqahpdzdk0rmkmhh7vdcrl3p"))
(patches (search-patches "libdrm-symbol-check.patch"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
`(#:configure-flags
'(,@(match (%current-system)
- ("armhf-linux"
- '("--enable-exynos-experimental-api"
- "--enable-omap-experimental-api"
- "--enable-etnaviv-experimental-api"
- "--enable-tegra-experimental-api"
- "--enable-freedreno-kgsl"))
- ("aarch64-linux"
- '("--enable-tegra-experimental-api"
- "--enable-etnaviv-experimental-api"
- "--enable-freedreno-kgsl"))
- (_ '())))))
+ ((or "armhf-linux" "aarch64-linux")
+ '("-Dexynos=true"
+ "-Domap=true"
+ "-Detnaviv=true"
+ "-Dtegra=true"
+ "-Dfreedreno-kgsl=true"))
+ (_ '())))
+ ,@(if (string=? (%current-system) "armhf-linux")
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "meson" "test" "--timeout-multiplier" "5")))))
+ '())))
(inputs
`(("libpciaccess" ,libpciaccess)))
(native-inputs
@@ -807,7 +810,7 @@ Guile will work for XBindKeys.")
(define-public sxhkd
(package
(name "sxhkd")
- (version "0.5.9")
+ (version "0.6.0")
(source
(origin
(method git-fetch)
@@ -815,8 +818,7 @@ Guile will work for XBindKeys.")
(url "https://github.com/baskerville/sxhkd")
(commit version)))
(sha256
- (base32
- "0cw547x7vky55k3ksrmzmrra4zhslqcwq9xw0y4cmbvy4s1qf64v"))))
+ (base32 "1cz4vkm7fqd51ly9qjkf5q76kdqdzfhaajgvrs4anz5dyzrdpw68"))))
(build-system gnu-build-system)
(inputs
`(("asciidoc" ,asciidoc)