summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2020-11-14 10:15:47 +0800
committer宋文武 <iyzsong@member.fsf.org>2020-11-14 10:23:07 +0800
commit7f9888e53f4632be80d1e7c09fc91a9d0b556236 (patch)
tree125343359af5ba8a862f72600819533327d11659 /gnu/packages/xdisorg.scm
parent0404b28dc74348e984dffe303481652c46b0b940 (diff)
downloadguix-patches-7f9888e53f4632be80d1e7c09fc91a9d0b556236.tar
guix-patches-7f9888e53f4632be80d1e7c09fc91a9d0b556236.tar.gz
gnu: Add sx.
* gnu/packages/xdisorg.scm (sx): New variable.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ead74ebe1c..b41111c215 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2550,3 +2550,35 @@ such as sway, similar to @command{rofi}.")
"@command{dex}, @dfn{DesktopEntry Execution}, is a program to generate
and execute @file{.desktop} files of the Application type.")
(license license:gpl3+)))
+
+(define-public sx
+ (package
+ (name "sx")
+ (version "2.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Earnestly/sx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p24ghp1ygvyc2hv81byhxax7491yhcc5priq5ldv07nzl7akagc"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" out)))
+ #:phases
+ (modify-phases %standard-phases
+ ;; no configure script
+ (delete 'configure))))
+ (propagated-inputs
+ `(("xauth" ,xauth)))
+ (home-page "https://github.com/Earnestly/sx")
+ (synopsis "Start an xorg server")
+ (description
+ "@command{sx} is a simple alternative to both @command{xinit} and
+@command{startx} for starting an Xorg server.")
+ (license license:x11)))