summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorRenzo Poddighe <renzo@poddighe.nl>2021-05-15 20:27:25 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-22 23:42:28 +0200
commit6a54e8138bda39722c9418d4cb674f53ecc4e594 (patch)
tree2cb7259c0c0b158dc24969836bd3bb522f9163d5 /gnu/packages/xdisorg.scm
parentcfec09a9928e171a724f630ba652ea0241d52e92 (diff)
downloadguix-patches-6a54e8138bda39722c9418d4cb674f53ecc4e594.tar
guix-patches-6a54e8138bda39722c9418d4cb674f53ecc4e594.tar.gz
gnu: Add jumpapp.
* gnu/packages/xdisorg.scm (jumpapp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 83fefecedc..6d7794ef43 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Renzo Poddighe <renzo@poddighe.nl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2796,3 +2797,44 @@ and execute @file{.desktop} files of the Application type.")
"The @command{hsetroot} command composes wallpapers for X.
This package is the fork of hsetroot by Hyriand.")
(license license:gpl2+)))
+
+(define-public jumpapp
+ (package
+ (name "jumpapp")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkropat/jumpapp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jrk4mm42sz6ca2gkb6w3dad53d4im4shpgsq8s4vr6xpl3b43ry"))))
+ (build-system gnu-build-system)
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-before 'install 'set-prefix-in-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PREFIX =.*")
+ (string-append "PREFIX = " out "\n")))
+ #true))))))
+ (propagated-inputs
+ `(("wmctrl" ,wmctrl)
+ ("xdotool" ,xdotool)
+ ("xprop" ,xprop)))
+ (native-inputs
+ `(("pandoc" ,pandoc)
+ ("perl" ,perl)))
+ (synopsis "Run-or-raise application switcher for any X11 desktop")
+ (description
+ "Bind a key for any given application that will launch the application,
+if it's not already running, or focus the application's window,if it is running.
+Pressing the key again will cycle to the application's next window,
+if there's more than one.")
+ (home-page "https://github.com/mkropat/jumpapp")
+ (license license:expat)))