summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorr0man <roman@burningswell.com>2022-07-16 11:13:54 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-03 12:18:32 +0200
commit45456595ac4ba613c8a61ff4f51088efd4157e6e (patch)
tree0c8469e2417ff7dd5fa25de4a1005d7612b67e50 /gnu/packages/xdisorg.scm
parent28e523cc327b9f5b33b769f11de492859e4cd32e (diff)
downloadguix-patches-45456595ac4ba613c8a61ff4f51088efd4157e6e.tar
guix-patches-45456595ac4ba613c8a61ff4f51088efd4157e6e.tar.gz
gnu: xscreensaver: Update to 6.04.
* gnu/packages/xdisorg.scm (xscreensaver): Update to 6.04. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm26
1 files changed, 21 insertions, 5 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5b54d02e2e..42f61ad0ce 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1627,7 +1627,7 @@ less if you are working in front of the screen at night.")
(define-public xscreensaver
(package
(name "xscreensaver")
- (version "5.45")
+ (version "6.04")
(source
(origin
(method url-fetch)
@@ -1635,7 +1635,7 @@ less if you are working in front of the screen at night.")
(string-append "https://www.jwz.org/xscreensaver/xscreensaver-"
version ".tar.gz"))
(sha256
- (base32 "03fmyjlwjinzv7mih6n07glmys8s877snd8zijk2c0ds6rkxy5kh"))))
+ (base32 "0lmiyvp3qs2gngd53f191jmlizs9l04i2gnrqbn96mqckyr18w3q"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -1646,9 +1646,24 @@ less if you are working in front of the screen at night.")
(substitute* '("driver/Makefile.in" "po/Makefile.in.in")
(("@GTK_DATADIR@") "@datadir@")
(("@PO_DATADIR@") "@datadir@"))
- #t)))
- #:configure-flags '("--with-pam" "--with-proc-interrupts"
- "--without-readdisplay")
+ #t))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The tarball uses a very old version of autconf. It does not
+ ;; understand extra flags like `--enable-fast-install', so
+ ;; we need to invoke it with just what it understands.
+ (let ((out (assoc-ref outputs "out")))
+ ;; 'configure' doesn't understand '--host'.
+ ,@(if (%current-target-system)
+ `((setenv "CHOST" ,(%current-target-system)))
+ '())
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (setenv "SHELL" (which "bash"))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ "--with-pam"
+ "--with-proc-interrupts"
+ "--without-readdisplay")))))
#:make-flags (list (string-append "AD_DIR="
(assoc-ref %outputs "out")
"/lib/X11/app-defaults"))))
@@ -1668,6 +1683,7 @@ less if you are working in front of the screen at night.")
("libjpeg" ,libjpeg-turbo)
("linux-pam" ,linux-pam)
("pango" ,pango)
+ ("gdk-pixbuf-xlib", gdk-pixbuf-xlib)
("gtk+" ,gtk+)
("perl" ,perl)
("cairo" ,cairo)