summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2020-12-06 21:36:11 +0800
committerLudovic Courtès <ludo@gnu.org>2020-12-11 19:06:54 +0100
commit382e0fee7f1cf982e33cf70d43e078e0b8572547 (patch)
treefb46786963dfc1cc787881b19b0baa9e03607572 /gnu/packages/xdisorg.scm
parent41d01b4e2e74a3e655bac03c241f0de7cb34b75f (diff)
downloadguix-patches-382e0fee7f1cf982e33cf70d43e078e0b8572547.tar
guix-patches-382e0fee7f1cf982e33cf70d43e078e0b8572547.tar.gz
gnu: Add hsetroot.
* gnu/packages/xdisorg.scm (hsetroot): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7c4148c87f..93f23d6722 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2618,3 +2619,43 @@ and execute @file{.desktop} files of the Application type.")
"@command{sx} is a simple alternative to both @command{xinit} and
@command{startx} for starting an Xorg server.")
(license license:x11)))
+
+(define-public hsetroot
+ (package
+ (name "hsetroot")
+ (version "1.0.5")
+ (home-page "https://github.com/himdel/hsetroot")
+ (source (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (sha256
+ (base32
+ "1jbk5hlxm48zmjzkaq5946s58rqwg1v1ds2sdyd2ba029hmvr722"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list
+ "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'mkdir-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))))))))
+ (inputs
+ `(("libx11" ,libx11)
+ ("imlib2" ,imlib2)
+ ("libxinerama" ,libxinerama)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Imlib2-based wallpaper changer")
+ (description
+ "The @command{hsetroot} command composes wallpapers for X.
+This package is the fork of hsetroot by Hyriand.")
+ (license license:gpl2+)))