summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorJosh Holland <josh@inv.alid.pw>2019-10-29 19:02:37 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-29 20:33:14 +0100
commit2f490bf3d6bb0197b4f280d7a18e9d34b7bb57c3 (patch)
treef2c695cab84a98840bda60ac77f77baf98a52209 /gnu/packages/xdisorg.scm
parent532dba49ca7f04138c4eae3e4961a102c64da2a9 (diff)
downloadguix-patches-2f490bf3d6bb0197b4f280d7a18e9d34b7bb57c3.tar
guix-patches-2f490bf3d6bb0197b4f280d7a18e9d34b7bb57c3.tar.gz
gnu: Add bemenu.
* gnu/packages/xdisorg.scm (bemenu): New public variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index cb2f9d40ae..17dc16b44c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Kyle Andrews <kyle.c.andrews@gmail.com>
+;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -190,6 +191,43 @@ that can be activated based on the connected hardware. Hook scripts can be
used to further tweak the behaviour of the different profiles.")
(license license:gpl3+))))
+(define-public bemenu
+ (package
+ (name "bemenu")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Cloudef/bemenu.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0piax49az5kp96r1g6dcgj87fi6p4jl286wlkxsdvljzpkn8q6gv"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags '("-DBEMENU_WAYLAND_RENDERER=ON")))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)
+ ("libxkbcomon" ,libxkbcommon)
+ ("libxinerama" ,libxinerama)
+ ("ncurses" ,ncurses)
+ ("pango" ,pango)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/Cloudef/bemenu")
+ (synopsis "Dynamic menu library and client program inspired by dmenu")
+ (description
+ "bemenu is a dynamic menu which allows the user to flexibly select from a
+list of options (usually programs to launch). It renders the menu graphically
+with X11 or Wayland, or in a text terminal with ncurses.")
+ (license (list license:gpl3+ ; client program[s] and other sources
+ license:lgpl3+)))) ; library and bindings
+
(define-public xclip
(package
(name "xclip")