summaryrefslogtreecommitdiff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2016-11-15 22:53:22 +0200
committerLeo Famulari <leo@famulari.name>2016-11-25 00:38:10 -0500
commitb353c7d201fa964be1c5b86c8d8d6a7bbc7b5398 (patch)
treec517402f98390d0fc25183fe8ccae21d3dc316b9 /gnu/packages/wxwidgets.scm
parent2cd3b6fd03b987eb55b2ab9fd3817696d4f1a4d5 (diff)
downloadguix-patches-b353c7d201fa964be1c5b86c8d8d6a7bbc7b5398.tar
guix-patches-b353c7d201fa964be1c5b86c8d8d6a7bbc7b5398.tar.gz
gnu: Add python2-wxpython.
* gnu/packages/wxwidgets.scm (python2-wxpython): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 4efe7a13bc..b72567f259 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
+;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,6 +24,7 @@
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix l:)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system python)
#:use-module (guix build utils)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
@@ -32,6 +34,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages sdl)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xorg))
@@ -118,3 +121,72 @@ and many other languages.")
"gtk+"
(package-inputs wxwidgets))))
(name "wxwidgets-gtk2")))
+
+(define-public python2-wxpython
+ (package
+ (name "python2-wxpython")
+ (version "3.0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/wxpython/wxPython/"
+ version "/wxPython-src-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0qfzx3sqx4mwxv99sfybhsij4b5pc03ricl73h4vhkzazgjjjhfm"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (lambda (folder)
+ (delete-file-recursively (string-append "src/" folder))
+ '("expat" "jpeg" "png" "tiff" "zlib" "msw" "osx" "msdos"))
+ (substitute* '("wxPython/setup.py")
+ ;; setup.py tries to keep its own license the same as wxwidget's
+ ;; license (which it expects under $WXWIN/docs).
+ (("'preamble.txt', 'licence.txt', 'licendoc.txt', 'lgpl.txt'")
+ ""))))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f ; tests fail
+ #:configure-flags (list "WXPORT=gtk2"
+ "UNICODE=1")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'chdir
+ (lambda _
+ (chdir "wxPython")
+ #t))
+ (add-after 'chdir 'set-wx-out-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; By default, install phase tries to copy the wxPython headers in
+ ;; gnu/store/...-wxwidgets-3.0.2 , which it can't, so they are
+ ;; redirected to the output directory by setting WXPREFIX.
+ (substitute* "config.py"
+ (("= getWxConfigValue\\('--prefix'\\)")
+ (string-append "= '" (assoc-ref outputs "out") "'")))
+ (substitute* "wx/build/config.py"
+ (("= getWxConfigValue\\('--prefix'\\)")
+ (string-append "= '" (assoc-ref outputs "out") "'")))
+ #t))
+ (add-after 'set-wx-out-dir 'setenv
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (setenv "WXWIN" (assoc-ref inputs "wxwidgets"))
+ (use-modules (ice-9 popen) (ice-9 rdelim))
+ (let ((port (open-pipe* OPEN_READ
+ (string-append (assoc-ref inputs "wxwidgets")
+ "/bin/wx-config") "--cppflags")))
+ (setenv "CPPFLAGS" (read-string port))
+ (close-pipe port))
+ #t)))))
+ (native-inputs
+ `(("mesa" ,mesa) ; for glcanvas
+ ("pkg-config" ,pkg-config)
+ ("python2-setuptools" ,python2-setuptools)))
+ (inputs
+ `(("gtk+" ,gtk+-2) ; for wxPython/src/helpers.cpp
+ ("wxwidgets" ,wxwidgets-gtk2)))
+ (synopsis "Python 2 Bindings for wxWidgets")
+ (description "@code{wxpython} provides Python 2 bindings for wxWidgets.")
+ (home-page "http://wxpython.org/")
+ (license (package-license wxwidgets))))