summaryrefslogtreecommitdiff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 18:06:24 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 18:39:14 +0100
commit6f1dcafd81940f8f78ac0d2f3adad3d339828765 (patch)
tree47cd6e451e80b8d62185f6f4d77026f847cf0eeb /gnu/packages/wxwidgets.scm
parentc415f76302a4c4ba3d8f9279e0b5142f111b21af (diff)
downloadguix-patches-6f1dcafd81940f8f78ac0d2f3adad3d339828765.tar
guix-patches-6f1dcafd81940f8f78ac0d2f3adad3d339828765.tar.gz
gnu: wxPython: Fix build.
* gnu/packages/wxwidgets.scm (python2-wxpython) [arguments]: Disable installation via setuptools (and --single-version-externally-managed).
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index b72567f259..a65c969e5c 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -149,6 +149,9 @@ and many other languages.")
(arguments
`(#:python ,python-2
#:tests? #f ; tests fail
+ ;; wxPython directly extends distutils command classes,
+ ;; we can't easily make setup.py use setuptools.
+ #:use-setuptools? #f
#:configure-flags (list "WXPORT=gtk2"
"UNICODE=1")
#:phases