summaryrefslogtreecommitdiff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-04-20 18:33:07 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-05-10 09:32:49 +0200
commit1d5b3f432efa59ea7604380ca3fd0f8771ae3ecf (patch)
treeaeb3c980af145593113c1f9962ea97e620bbfbe6 /gnu/packages/wxwidgets.scm
parentb5b20bda17acfce8802e067f1ca015c65f4d3cf8 (diff)
downloadguix-patches-1d5b3f432efa59ea7604380ca3fd0f8771ae3ecf.tar
guix-patches-1d5b3f432efa59ea7604380ca3fd0f8771ae3ecf.tar.gz
gnu: Add wxwidgets-3.1.
* gnu/packages/wxwidgets.scm (wxwidgets-3.1): New variable.
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 329920d7c1..cf4329a6ce 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module (guix build utils)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
@@ -102,6 +104,27 @@ and many other languages.")
(package-inputs wxwidgets))))
(name "wxwidgets-gtk2")))
+;; Development version of wxWidgets, required to build against gstreamer-1.x.
+;; This can be removed when wxWidgets is updated to the next stable version.
+(define-public wxwidgets-3.1
+ (package (inherit wxwidgets)
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/wxWidgets/wxWidgets/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append "wxwidgets-" version ".tar.gz"))
+ (sha256
+ (base32 "1yan5ysjwh6a7xw82sfjd1xn0nsy1dn2s0cx9ac7cw19191blc3y"))))
+ (inputs `(("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ,@(package-inputs wxwidgets)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments wxwidgets)
+ ((#:configure-flags flags)
+ `(cons "--enable-mediactrl" ,flags))))))
+
(define-public python2-wxpython
(package
(name "python2-wxpython")