summaryrefslogtreecommitdiff
path: root/gnu/packages/wv.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-23 18:00:54 -0400
committerLeo Famulari <leo@famulari.name>2017-06-24 23:10:28 -0400
commitd17e085a59534a333cb8db028579fd0e6ec7f89b (patch)
treea14cac3625e0f78c2ca4ac91ae92e8525ced4e23 /gnu/packages/wv.scm
parent68f30310e13e77079a55b8db368ead7698cb99dc (diff)
downloadguix-patches-d17e085a59534a333cb8db028579fd0e6ec7f89b.tar
guix-patches-d17e085a59534a333cb8db028579fd0e6ec7f89b.tar.gz
gnu: Remove libwmf.
This package contains many security vulnerabilities and is no longer maintained upstream. See this discussion for more information: https://lists.gnu.org/archive/html/guix-devel/2017-05/msg00478.html * gnu/packages/image.scm (libwmf): Remove variable. * gnu/packages/wv.scm (wv)[inputs]: Remove libwmf. [arguments]: Remove field. * gnu/packages/abiword.scm (abiword)[inputs]: Remove libwmf. [source]: Remove patch 'abiword-wmf-version-lookup-fix.patch'. * gnu/packages/patches/abiword-wmf-version-lookup-fix.patch, gnu/packages/patches/libwmf-CAN-2004-0941.patch, gnu/packages/patches/libwmf-CVE-2006-3376.patch, gnu/packages/patches/libwmf-CVE-2007-0455.patch, gnu/packages/patches/libwmf-CVE-2007-2756.patch, gnu/packages/patches/libwmf-CVE-2007-3472.patch, gnu/packages/patches/libwmf-CVE-2007-3473.patch, gnu/packages/patches/libwmf-CVE-2007-3477.patch, gnu/packages/patches/libwmf-CVE-2009-1364.patch, gnu/packages/patches/libwmf-CVE-2009-3546.patch, gnu/packages/patches/libwmf-CVE-2015-0848+CVE-2015-4588.patch, gnu/packages/patches/libwmf-CVE-2015-4695.patch, gnu/packages/patches/libwmf-CVE-2015-4696.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/wv.scm')
-rw-r--r--gnu/packages/wv.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/wv.scm b/gnu/packages/wv.scm
index a7f294462b..12201faa3a 100644
--- a/gnu/packages/wv.scm
+++ b/gnu/packages/wv.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,16 +40,12 @@
(sha256
(base32
"1mn2ax6qjy3pvixlnvbkn6ymy6y4l2wxrr4brjaczm121s8hjcb7"))))
-
(build-system gnu-build-system)
- (arguments
- `(#:configure-flags '("--with-libwmf")))
(inputs
`(("glib" ,glib)
("libgsf" ,libgsf)
("libjpeg" ,libjpeg)
("libpng" ,libpng)
- ("libwmf" ,libwmf)
("zlib" ,zlib)))
(native-inputs
`(("glib" ,glib "bin")