summaryrefslogtreecommitdiff
path: root/gnu/packages/wordnet.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-30 22:46:46 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-31 00:04:00 +0100
commitfc12c5237c459ca13ac920b518aea4db8faa4555 (patch)
tree1259c46f8561bfd305e72565aed4b6c15e457003 /gnu/packages/wordnet.scm
parentcd60284dc6132405b8268e2881c1f62d524845a5 (diff)
downloadguix-patches-fc12c5237c459ca13ac920b518aea4db8faa4555.tar
guix-patches-fc12c5237c459ca13ac920b518aea4db8faa4555.tar.gz
gnu: wordnet: Include PIC objects in libWN.a.
Fixes a Dico build failure introduced in commit a6a9e628693ed2d49cd9cdfca597fd4e63bbdef0. * gnu/packages/wordnet.scm (wordnet)[arguments]: Add 'build-libwn-PIC' phase.
Diffstat (limited to 'gnu/packages/wordnet.scm')
-rw-r--r--gnu/packages/wordnet.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/wordnet.scm b/gnu/packages/wordnet.scm
index 8d969360cd..abec2f0e50 100644
--- a/gnu/packages/wordnet.scm
+++ b/gnu/packages/wordnet.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -55,6 +55,12 @@
"CFLAGS=-DUSE_INTERP_RESULT -O2")
#:phases
(modify-phases %standard-phases
+ (add-before 'build 'build-libwn-PIC
+ (lambda _
+ ;; GNU Dico links libWN.a in its wordnet.so plugin, so it needs
+ ;; PIC.
+ (invoke "make" "-C" "lib" "CFLAGS=-O2 -g -fPIC"
+ "LDFLAGS=-fPIC")))
(add-after 'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))