summaryrefslogtreecommitdiff
path: root/gnu/packages/wordnet.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 20:11:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 20:14:06 +0300
commitc1dbd3a8709f143fa72b2f893a069ca5f1afe7ac (patch)
tree7e0bbffad2155d1a4d46d603b7ecc4442cd7040d /gnu/packages/wordnet.scm
parent1f521b7055a464439774332f1a69ed31b565715f (diff)
downloadguix-patches-c1dbd3a8709f143fa72b2f893a069ca5f1afe7ac.tar
guix-patches-c1dbd3a8709f143fa72b2f893a069ca5f1afe7ac.tar.gz
gnu: wordnet: Fix CVE-2008-2149, CVE-2008-3908.
* gnu/packages/wordnet.scm (wordnet)[source]: Add patches. * gnu/packages/patches/wordnet-CVE-2008-2149.patch, gnu/packages/patches/wordnet-CVE-2008-3908-pt1.patch, gnu/packages/patches/wordnet-CVE-2008-3908-pt2.patch: New variables. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/wordnet.scm')
-rw-r--r--gnu/packages/wordnet.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/wordnet.scm b/gnu/packages/wordnet.scm
index 1823a624ed..9cd7a56104 100644
--- a/gnu/packages/wordnet.scm
+++ b/gnu/packages/wordnet.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
#:use-module (guix download)
+ #:use-module (gnu packages)
#:use-module (gnu packages tcl))
(define-public wordnet
@@ -30,11 +32,14 @@
(source (origin
(method url-fetch)
(uri (string-append "http://wordnetcode.princeton.edu/"
- version "/WordNet-"
- version ".tar.bz2"))
+ version "/WordNet-" version ".tar.bz2"))
(sha256
(base32
- "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))))
+ "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))
+ (patches (search-patches
+ "wordnet-CVE-2008-2149.patch"
+ "wordnet-CVE-2008-3908-pt1.patch"
+ "wordnet-CVE-2008-3908-pt2.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "--with-tcl="