summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-27 19:05:45 -0500
committerMathieu Othacehe <othacehe@gnu.org>2021-12-02 15:44:31 +0100
commitfab80c36720bbdb85730708d0dc5fceabcc22a6e (patch)
treef1271418ede78ee25f291aea0f833069e5e1a008 /gnu/packages/wm.scm
parent28ad55a59d96ac0d0b1351b387040d25cd3810d4 (diff)
downloadguix-patches-fab80c36720bbdb85730708d0dc5fceabcc22a6e.tar
guix-patches-fab80c36720bbdb85730708d0dc5fceabcc22a6e.tar.gz
gnu: Add trayer-srg.
* gnu/packages/wm.scm (trayer-srg): New variable. Co-authored-by: Disseminate Dissent <disseminatedissent@protonmail.com> Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4740d26024..0733198e65 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -46,6 +46,8 @@
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Disseminate Dissent <disseminatedissent@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2659,6 +2661,47 @@ capabilities. It is heavily inspired by the Calm Window manager(cwm).")
program and unhides it after quitting.")
(license license:gpl2)))
+(define-public trayer-srg
+ (package
+ (name "trayer-srg")
+ (version "1.1.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sargon/trayer-srg")
+ (commit (string-append "trayer-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mvhwaqa9bng9wh3jg3b7y8gl7nprbydmhg963xg0r076jyzv0cg"))))
+ (native-inputs
+ `(("libxmu" ,libxmu)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gtk+" ,gtk+-2)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output)))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (apply invoke "./configure" configure-flags))))))
+ (home-page "https://github.com/sargon/trayer-srg")
+ (synopsis "Minimal GTK based system tray")
+ (description
+ "@command{trayer} is small program designed to provide systray
+functionality present in GNOME/KDE desktop enviroments for window managers
+which do not support it.")
+ (license license:expat)))
+
(define-public wlogout
(package
(name "wlogout")